<!DOCTYPE html>
<html lang="en"
      dir="ltr" 
  xmlns:fb="http://www.facebook.com/2008/fbml"
  xmlns:og="http://ogp.me/ns#"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.5.0/css/all.css" integrity="sha384-B4dIYHKNBt8Bc12p+WXckhzcICo0wtJAoU8YZTY5qE0Id1GSseTk6S+L3BlXeVIU" crossorigin="anonymous">
<link rel="shortcut icon" href="https://www.barbadosadvocate.com/sites/barbadosadvocate.com/files/favicon.jpg" type="image/jpeg" />
<meta name="theme-color" content="#ffffff" />
<meta name="description" content="Therese Turner-Jones, General Manager, Caribbean Country Department, Inter-American Develop-ment Bank (IDB), is of the belief that the region is not ready to operate in a virtual state." />
<meta name="generator" content="Drupal 7 (https://www.drupal.org)" />
<link rel="canonical" href="https://www.barbadosadvocate.com/news/caribbean-digitally-unprepared-covid-19" />
<link rel="shortlink" href="https://www.barbadosadvocate.com/node/203501" />
<meta property="og:site_name" content="Barbados Advocate" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.barbadosadvocate.com/news/caribbean-digitally-unprepared-covid-19" />
<meta property="og:title" content="Caribbean digitally unprepared for COVID-19" />
<meta property="og:description" content="Therese Turner-Jones, General Manager, Caribbean Country Department, Inter-American Develop-ment Bank (IDB), is of the belief that the region is not ready to operate in a virtual state." />
<meta property="og:updated_time" content="2020-03-31T05:33:24-04:00" />
<meta property="og:image" content="https://www.barbadosadvocate.com/sites/barbadosadvocate.com/files/field/image/1Therese%20Turner-Jones.jpg" />
<meta property="article:published_time" content="2020-03-31T05:00:44-04:00" />
<meta property="article:modified_time" content="2020-03-31T05:33:24-04:00" />
    <title>Caribbean digitally unprepared for COVID-19 | Barbados Advocate</title>
    <style type="text/css" media="all">
@import url("https://www.barbadosadvocate.com/modules/system/system.base.css?q824ak");
@import url("https://www.barbadosadvocate.com/modules/system/system.menus.css?q824ak");
@import url("https://www.barbadosadvocate.com/modules/system/system.messages.css?q824ak");
@import url("https://www.barbadosadvocate.com/modules/system/system.theme.css?q824ak");
</style>
<style type="text/css" media="all">
@import url("https://www.barbadosadvocate.com/modules/aggregator/aggregator.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/modules/calendar/css/calendar_multiday.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/modules/date/date_api/date.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/modules/date/date_popup/themes/datepicker.1.7.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/modules/date/date_repeat_field/date_repeat_field.css?q824ak");
@import url("https://www.barbadosadvocate.com/modules/field/theme/field.css?q824ak");
@import url("https://www.barbadosadvocate.com/modules/node/node.css?q824ak");
@import url("https://www.barbadosadvocate.com/modules/poll/poll.css?q824ak");
@import url("https://www.barbadosadvocate.com/modules/search/search.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/modules/simpleads/simpleads.css?q824ak");
@import url("https://www.barbadosadvocate.com/modules/user/user.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/modules/extlink/extlink.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/modules/views/css/views.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/modules/ckeditor/css/ckeditor.css?q824ak");
</style>
<style type="text/css" media="all">
@import url("https://www.barbadosadvocate.com/sites/all/modules/ed_classified/theme/classified.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/modules/ctools/css/ctools.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/modules/etype/css/etype.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/libraries/superfish/css/superfish.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/libraries/superfish/css/superfish-navbar.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/libraries/superfish/style/space.css?q824ak");
</style>
<style type="text/css" media="all">
@import url("https://www.barbadosadvocate.com/sites/all/themes/cni/css/normalize.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/themes/cni/css/formalize.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/themes/cni/css/grid_12.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/themes/cni/css/layout.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/themes/cni/css/jcarousel.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/themes/cni/css/galleria.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/all/themes/cni/css/style.css?q824ak");
@import url("https://www.barbadosadvocate.com/sites/barbadosadvocate.com/themes/barbadosadvocate/css/barbadosadvocate.css?q824ak");
</style>
<link type="text/css" rel="stylesheet" href="https://www.barbadosadvocate.com/sites/all/themes/cni/css/menu_break_767.css?q824ak" media="all" />
<style type="text/css" media="screen">
<!--/*--><![CDATA[/*><!--*/
#block-superfish-1, .sf-menu.sf-style-space li, .sf-menu.sf-style-space li li, .sf-menu.sf-style-space li li li, .sf-menu.sf-style-space.sf-navbar {background: #FF0000 !important;}#main-menu ul.menu {max-width: 600px !important;}.site-logo img {max-width: 1200px !important;}
/*]]>*/-->
</style>
    <script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.jQuery || document.write("<script src='/sites/all/modules/jquery_update/replace/jquery/1.8/jquery.min.js'>\x3C/script>")
//--><!]]>
</script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/misc/jquery-extend-3.4.0.js?v=1.8.3"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/misc/jquery.once.js?v=1.2"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/misc/drupal.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/modules/simpleads/simpleads.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/modules/simpleads/modules/simpleads_campaigns/simpleads_campaigns.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/modules/extlink/extlink.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/modules/google_analytics/googleanalytics.js?q824ak"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-79882000-1", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56e774978692f861"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/modules/etype/js/etype.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/libraries/superfish/jquery.hoverIntent.minified.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/libraries/superfish/sfsmallscreen.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/libraries/superfish/superfish.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/libraries/superfish/supersubs.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/modules/superfish/superfish.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/themes/cni/js/jquery.color.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/themes/cni/js/jquery-glowing.js?q824ak"></script>
<script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/themes/cni/js/scripts.js?q824ak"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"barbadosadvocate","theme_token":"LNyWSxM3YBdRaqQ9TnIHJesv0WGWe-FyIN7KaKIuHI0","js":{"sites\/all\/modules\/addthis\/addthis.js":1,"\/\/ajax.googleapis.com\/ajax\/libs\/jquery\/1.8.3\/jquery.min.js":1,"0":1,"misc\/jquery-extend-3.4.0.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/simpleads\/simpleads.js":1,"sites\/all\/modules\/simpleads\/modules\/simpleads_campaigns\/simpleads_campaigns.js":1,"sites\/all\/modules\/extlink\/extlink.js":1,"sites\/all\/modules\/google_analytics\/googleanalytics.js":1,"1":1,"\/\/s7.addthis.com\/js\/300\/addthis_widget.js#pubid=ra-56e774978692f861":1,"sites\/all\/modules\/etype\/js\/etype.js":1,"sites\/all\/libraries\/superfish\/jquery.hoverIntent.minified.js":1,"sites\/all\/libraries\/superfish\/sfsmallscreen.js":1,"sites\/all\/libraries\/superfish\/superfish.js":1,"sites\/all\/libraries\/superfish\/supersubs.js":1,"sites\/all\/modules\/superfish\/superfish.js":1,"sites\/all\/themes\/cni\/js\/jquery.color.js":1,"sites\/all\/themes\/cni\/js\/jquery-glowing.js":1,"sites\/all\/themes\/cni\/js\/scripts.js":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"modules\/aggregator\/aggregator.css":1,"sites\/all\/modules\/calendar\/css\/calendar_multiday.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"sites\/all\/modules\/date\/date_repeat_field\/date_repeat_field.css":1,"modules\/field\/theme\/field.css":1,"modules\/node\/node.css":1,"modules\/poll\/poll.css":1,"modules\/search\/search.css":1,"sites\/all\/modules\/simpleads\/simpleads.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/extlink\/extlink.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/ed_classified\/theme\/classified.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/etype\/css\/etype.css":1,"sites\/all\/libraries\/superfish\/css\/superfish.css":1,"sites\/all\/libraries\/superfish\/css\/superfish-navbar.css":1,"sites\/all\/libraries\/superfish\/style\/space.css":1,"sites\/all\/themes\/cni\/css\/normalize.css":1,"sites\/all\/themes\/cni\/css\/formalize.css":1,"sites\/all\/themes\/cni\/css\/grid_12.css":1,"sites\/all\/themes\/cni\/css\/layout.css":1,"sites\/all\/themes\/cni\/css\/jcarousel.css":1,"sites\/all\/themes\/cni\/css\/galleria.css":1,"sites\/all\/themes\/cni\/css\/style.css":1,"sites\/barbadosadvocate.com\/themes\/barbadosadvocate\/css\/barbadosadvocate.css":1,"sites\/all\/themes\/cni\/css\/menu_break_767.css":1,"0":1,"1":1,"2":1}},"jcarousel":{"ajaxPath":"\/jcarousel\/ajax\/views"},"simpleads":{"url":{"ckeditor":"\/simpleads\/dashboard\/ckeditor"},"modulepath":"sites\/all\/modules\/simpleads"},"extlink":{"extTarget":0,"extClass":"ext","extLabel":"(link is external)","extImgClass":0,"extIconPlacement":"append","extSubdomains":1,"extExclude":"","extInclude":"","extCssExclude":"","extCssExplicit":"","extAlert":0,"extAlertText":"This link will take you to an external web site. We are not responsible for their content.","mailtoClass":"mailto","mailtoLabel":"(link sends e-mail)"},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"urlIsAjaxTrusted":{"\/news\/caribbean-digitally-unprepared-covid-19":true},"superfish":{"1":{"id":"1","sf":{"pathClass":"active-trail","pathLevels":"2","animation":{"opacity":"show"},"speed":"\u0027normal\u0027","autoArrows":false,"dropShadows":true,"disableHI":false},"plugins":{"smallscreen":{"mode":"window_width","addSelected":false,"menuClasses":false,"hyperlinkClasses":false,"title":"Main menu"},"supposition":false,"bgiframe":false,"supersubs":{"minWidth":"12","maxWidth":"27","extraWidth":1}}}},"cni":{"menu_break_point":"767"}});
//--><!]]>
</script>
    <meta name="viewport"
          content="width=device-width, initial-scale=1, maximum-scale=1">
    <link href='//fonts.googleapis.com/css?family=Lato|Anton|Roboto' rel='stylesheet'
          type='text/css'>
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
    </head>
<body class="html not-front not-logged-in one-sidebar sidebar-first page-node page-node- page-node-203501 node-type-article barbadosadvocate sidebars-split news caribbean-digitally-unprepared-covid-19">
<div id="fb-root"></div>
<script>(function (d, s, id) {
        var js, fjs = d.getElementsByTagName(s)[0];
        if (d.getElementById(id)) return;
        js = d.createElement(s);
        js.id = id;
        js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
        fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));</script>
<div id="skip-link">
    <a href="#main-content"
       class="element-invisible element-focusable">Skip to main content</a>
</div>
<div id="page-top">

    
            <nav id="user-menu" class="clearfix">
              <div class="region region-user-menu">
    <div id="block-search-form"
     class="block block-search">
    <div class="block-inner">

                  
        <div class="content">
          <form onsubmit="if(this.search_block_form.value==&#039;Search&#039;){ alert(&#039;Please enter a search&#039;); return false; }" action="/news/caribbean-digitally-unprepared-covid-19" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-4muUpVwvAafPP7PBCLfRy5lPGvj2rMyy_p0FA-Eq_gk" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>        </div>

    </div>
</div>
  </div>
                    </nav>
    
    <div class="page-inner container_12">

        
        <div class="header-wrapper clearfix">
            <div class="header-wrapper-inner grid_12">
                <header>

                                            <div class="site-logo">
                        <a href="/"><img
                                    src="https://www.barbadosadvocate.com/sites/barbadosadvocate.com/files/advocate-website-banner_935px.jpg"
                                    alt="Barbados Advocate Logo"/></a>
                        </div>  <div class="region region-header">
    <div id="block-simpleads-ad-groups-1409"
     class="block block-simpleads">
    <div class="block-inner">

                  
        <div class="content">
          <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-1409', 1409, 25);
  </script>
    <div class="simpleads-1409"></div>

    
</div>
        </div>

    </div>
</div>
  </div>
                    
                </header>

            </div>
        </div>

    </div>
</div>


    <div class="main-menu-wrapper clearfix container_12">
        <div class="main-menu-wrapper-inner">
            <nav id="main-menu">
                  <div class="region region-main-menu">
    <div id="block-superfish-1"
     class="block block-superfish">
    <div class="block-inner">

                      <h3 class="title">
              <span>Main menu</span></h3>
            
        <div class="content">
          <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-navbar sf-style-space sf-total-items-7 sf-parent-items-0 sf-single-items-7"><li id="menu-656-1" class="first odd sf-item-1 sf-depth-1 sf-no-children"><a href="/" title="" class="sf-depth-1"><span>Home</span></a></li><li id="menu-1857-1" class="middle even sf-item-2 sf-depth-1 sf-no-children"><a href="/news" title="News" class="sf-depth-1"><span>News</span></a></li><li id="menu-1856-1" class="middle odd sf-item-3 sf-depth-1 sf-no-children"><a href="/business" title="Business" class="sf-depth-1"><span>Business</span></a></li><li id="menu-1858-1" class="middle even sf-item-4 sf-depth-1 sf-no-children"><a href="/sports" title="Sports" class="sf-depth-1"><span>Sports</span></a></li><li id="menu-1917-1" class="middle odd sf-item-5 sf-depth-1 sf-no-children"><a href="/columns" title="Columns" class="sf-depth-1"><span>Columns</span></a></li><li id="menu-694-1" class="middle even sf-item-6 sf-depth-1 sf-no-children"><a href="/contact" title="" class="sf-depth-1"><span>Contact Us</span></a></li><li id="menu-3490-1" class="last odd sf-item-7 sf-depth-1 sf-no-children"><a href="https://etypeservices.com/Barbados%20AdvocateID432/" title="" class="sf-depth-1"><span>E-Paper</span></a></li></ul>        </div>

    </div>
</div>
  </div>
            </nav>
        </div>
    </div>

    <div class="main-menu-second-level-wrapper clearfix container_12">
        <div class="main-menu-second-level-wrapper-inner">
            <nav id="main-menu-second-level">
                  <div class="region region-main-menu-second-level">
    <div id="block-simpleads-ad-groups-1469"
     class="block block-simpleads">
    <div class="block-inner">

                  
        <div class="content">
          <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-1469', 1469, 25);
  </script>
    <div class="simpleads-1469"></div>

    
</div>
        </div>

    </div>
</div>
  </div>
            </nav>
        </div>
    </div>

<div id="page">
    <div class="page-inner container_12">

        <!-- Main Content -->
        <div class="main-content-wrapper clearfix">
            <div class="main-content-wrapper-inner">
                <section id="main-content">

                    <div class="main">
                        <div class="main-inner grid_8">

                            
                                                                                                                                              <div class="region region-content">
    <div id="block-system-main"
     class="block block-system">
    <div class="block-inner">

                  
        <div class="content">
          <article id="node-203501" class="node node-article last clearfix" about="/news/caribbean-digitally-unprepared-covid-19" typeof="sioc:Item foaf:Document">

    <div class="node-content-wrapper">

                <div class="field-image">
            <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="og:image rdfs:seeAlso" resource="https://www.barbadosadvocate.com/sites/barbadosadvocate.com/files/styles/large/public/field/image/1Therese%20Turner-Jones.jpg?itok=kiC12Kh0"><img typeof="foaf:Image" src="https://www.barbadosadvocate.com/sites/barbadosadvocate.com/files/styles/large/public/field/image/1Therese%20Turner-Jones.jpg?itok=kiC12Kh0" width="618" height="412" alt="Article Image Alt Text" /><blockquote class="image-field-caption">
  <p>Therese Turner-Jones, General Manager, Caribbean Country Department, Inter-American Development Bank (IDB).</p>
</blockquote>
</div></div></div>          </div>
      
      
      
      
                <h1 class="title">Caribbean digitally unprepared for COVID-19</h1>
      
      <span property="dc:title" content="Caribbean digitally unprepared for COVID-19" class="rdf-meta element-hidden"></span>
                          <!-- Go to www.addthis.com/dashboard to customize your tools -->
          <div class="addthis_sharing_toolbox"></div>
                
                <div class="submitted clearfix">
              <span class="date"><span property="dc:date dc:created" content="2020-03-31T05:00:44-04:00" datatype="xsd:dateTime">Tue, 03/31/2020 - 5:00am</span></span>
          </div>
      
        <div class="content">
          <div class="field field-name-field-dateline field-type-text field-label-inline clearfix"><div class="field-label">By:&nbsp;</div><div class="field-items"><div class="field-item even">André Springer</div></div></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>Therese Turner-Jones, General Manager, Caribbean Country Department, Inter-American Develop-ment Bank (IDB), is of the belief that the region is not ready to operate in a virtual state.</p>
<p>In fact, during a webinar, “Coronavirus and the Caribbean: Economic Implications and Options”, hosted by the IDB Caribbean Department, Turner-Jones gave the region a rating of 5 out of 10 in terms of readiness.</p>
<p>“We are not nearly as ready as we should be. We have mobile devices, millions in the region. However, we do not have as much digital use, regarding services, government and private. For example, the banking systems, Caribbean people still do not trust online transactions.”</p>
<p>Turner-Jones also pointed out that the effects of COVID-19 on the region will probably create a different future, where financial institutions will move in the direction of leaning heavily on digital platforms. James Scriven, CEO, IDB Invest, announced that the IDB was working with large telecoms companies to build more physical infrastructure through the raising of additional towers in the region, to aid in not just boosting Internet coverage but quality as well, which would boost the coming digital age.</p>
<p>While the COVID-19 crisis is still in a significant fallout stage, thoughts towards the recovery phase are in the air. Turner-Jones addressed the concern of balancing the push to save the economies of the region versus protecting the people, saying the latter was more important.</p>
<p>“Put in whatever measures are necessary to stem the spread. We do not have robust healthcare infrastructure to battle an irresponsible response. We do not have enough ICUs (Intensive Care Units), ventilators and safety equipment. We all want to be sensible about this, we have to be careful.”</p>
<p>David Rosenblatt, Regional Economic Advisor, Caribbean Country Department, IDB, chimed in as well, highlighting that the region was accustomed to hurricanes which destroyed infrastructure, but in the case of COVID-19, that was not the case. However, Rosenblatt contended the region must save the people and that while buildings stood, if people became ill, there would be no workforce. He offered a solution for the downtime of educating staff for the virtual environment.</p>
<p>“You must protect the people. Are there measures to keep the business afloat? Yes, take the opportunity to retrain staff.”</p>
<p>The length of time for the recovery of the region was also questioned and Turner-Jones responded that the region had just begun to climb out of the 2008 recession hole. One of the positives discussed was that because it was a worldwide pandemic, a problem so big, that all hands needed to be on deck to collaborate. Turner-Jones urged the region to find the courage and be disciplined in their behaviour to face the crisis no one saw coming, while Scriven stated that it was a time to push the reset button.</p>
<p>“We are seeing the emergence of more humble human beings. When, not if, we get through this, I hope we can see the things we fight about are so trivial.”</p>
</div></div></div>        </div>

                    
                <nav class="taxonomy">
              <div class="taxonomy-inner clearfix">
                <div class="field field-name-field-section field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype=""><span>News</span></a></div></div></div>              </div>
          </nav>
      
                <nav class="taxonomy">
              <div class="taxonomy-inner clearfix">
                              </div>
          </nav>
      
    </div>

</article>


        </div>

    </div>
</div>
  </div>
                                                    </div>

                        <aside class="sidebar second-sidebar grid_4 clearfix">
                              <div class="region region-sidebar-first">
    <div id="block-simpleads-ad-groups-1410"
     class="block block-simpleads">
    <div class="block-inner">

                  
        <div class="content">
          <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-1410', 1410, 25);
  </script>
    <div class="simpleads-1410"></div>

    
</div>
        </div>

    </div>
</div>
<div id="block-etype-e-edition"
     class="block block-etype">
    <div class="block-inner">

                  
        <div class="content">
          
<p><a href="https://etypeservices.com/Barbados%20AdvocateID432/"><img src="https://etypeservices.com/LandingPageImages/Barbados%20Advocate/currentpg1.jpg" alt="Barbados Advocate e-Edition"></a></p>
<p><a href="https://etypeservices.com/Barbados%20AdvocateID432/">Click here to read Barbados Advocate</a></p>
        </div>

    </div>
</div>
<div id="block-block-35"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <a class="weatherwidget-io" href="https://forecast7.com/en/13d10n59d61/bridgetown/" data-label_1="BRIDGETOWN" data-label_2="WEATHER" data-theme="original" >BRIDGETOWN WEATHER</a>
<script>
!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src='https://weatherwidget.io/js/widget.min.js';fjs.parentNode.insertBefore(js,fjs);}}(document,'script','weatherwidget-io-js');
</script>        </div>

    </div>
</div>
<div id="block-simpleads-ad-groups-1470"
     class="block block-simpleads">
    <div class="block-inner">

                  
        <div class="content">
          <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-1470', 1470, 25);
  </script>
    <div class="simpleads-1470"></div>

    
</div>
        </div>

    </div>
</div>
  </div>
                                                    </aside>
                    </div>

                </section>
            </div>
        </div>

        
                    <div class="postscript-wrapper clearfix">
                <div class="postscript-wrapper-inner">
                    <div class="postscript-wrapper-inner-inner">
                        <section id="postscript">
                            <div class="grid_4">  <div class="region region-postscript-1">
    <div id="block-block-3"
     class="block block-block">
    <div class="block-inner">

                      <h3 class="title">
              <span>Barbados Advocate</span></h3>
            
        <div class="content">
          <p><strong>Mailing Address:</strong><br />
Advocate Publishers (2000) Inc<br />
Fontabelle, St. Michael, Barbados</p>
<p><strong>Phone:</strong> (246) 467-2000<br /><strong>Fax:</strong> (246) 434-2020 / (246) 434-1000</p>
        </div>

    </div>
</div>
  </div>
</div>
                            <div class="grid_4">  <div class="region region-postscript-2">
    <div id="block-menu-block-2"
     class="block block-menu-block">
    <div class="block-inner">

                      <h3 class="title">
              <span>Site Links</span></h3>
            
        <div class="content">
          <div class="menu-block-wrapper menu-block-2 menu-name-main-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="first leaf menu-mlid-656"><a href="/" title=""><span>Home</span></a></li>
<li class="leaf menu-mlid-1857"><a href="/news" title="News"><span>News</span></a></li>
<li class="leaf menu-mlid-1856"><a href="/business" title="Business"><span>Business</span></a></li>
<li class="leaf menu-mlid-1858"><a href="/sports" title="Sports"><span>Sports</span></a></li>
<li class="leaf menu-mlid-1917"><a href="/columns" title="Columns"><span>Columns</span></a></li>
<li class="leaf menu-mlid-694"><a href="/contact" title=""><span>Contact Us</span></a></li>
<li class="last leaf menu-mlid-3490"><a href="https://etypeservices.com/Barbados%20AdvocateID432/" title=""><span>E-Paper</span></a></li>
</ul></div>
        </div>

    </div>
</div>
<div id="block-menu-block-3"
     class="block block-menu-block">
    <div class="block-inner">

                  
        <div class="content">
          <div class="menu-block-wrapper menu-block-3 menu-name-user-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="first leaf menu-mlid-1190"><a href="/" title=""><span>Home</span></a></li>
<li class="leaf menu-mlid-699"><a href="/webforms" title=""><span>Forms &amp; Submissions </span></a></li>
<li class="leaf menu-mlid-3481"><a href="/ada-compliance" title="Americans with Disabilities Act Compliance Statement"><span>Accessibility Policy</span></a></li>
<li class="last leaf menu-mlid-2143"><a href="/e-edition" title="Read the e-Edition"><span>e-Edition</span></a></li>
</ul></div>
        </div>

    </div>
</div>
  </div>
</div>
                            <div class="grid_4"></div>
                        </section>
                                            </div>
                </div>
            </div>
                    </div>
</div><!-- page -->

<div id="page-bottom">
    </div><script type="text/javascript" src="https://www.barbadosadvocate.com/sites/all/modules/addthis/addthis.js?q824ak"></script>
</body>
</html>
